CVE-2026-44236: alanxz rabbitmq-c · Heap-based Buffer Overflow
Affects alanxz rabbitmq-cSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 0.16.0 soon.
Data as of 1 Nov 2026, 11:02 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 34% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.16.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade rabbitmq-c and alanxz/rabbitmq-c to 0.16.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| alanxzrabbitmq-c | Affected
| Fixed in
|
GitHubalanxz/rabbitmq-cpkg:github/alanxz/rabbitmq-cOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to rabbitmq-c version 0.16.0 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory.
Description
rabbitmq-c is a C-language AMQP client library for RabbitMQ. Prior to 0.16.0, a malicious AMQP server can send an undersized connection.tune.frame_max value during amqp_login(), and rabbitmq-c accepts the value in amqp_login_inner() in librabbitmq/amqp_socket.c. amqp_tune_connection() in librabbitmq/amqp_connection.c uses frame_max to reallocate the outbound buffer without enforcing AMQP_FRAME_MIN_SIZE. Immediate serialization of connection.tune-ok through amqp_frame_to_bytes() writes beyond the undersized heap allocation, causing memory corruption and likely denial of service. An on-path attacker can also trigger the flaw against plaintext AMQP traffic. Code execution is theoretically possible but was not demonstrated. This issue is fixed in version 0.16.0.
References
- github.com/alanxz/rabbitmq-c/security/advisories/GHSA-jh48-qjf5-fx5v (opens in a new tab)
- github.com/alanxz/rabbitmq-c/pull/879 (opens in a new tab)
- github.com/alanxz/rabbitmq-c/commit/4777d0b5c58cb02966a04a85832436bd66ed5d1f (opens in a new tab)
- github.com/alanxz/rabbitmq-c/releases/tag/v0.16.0 (opens in a new tab)