Skip to main content
VulnerabilityPublished

CVE-2026-44424: shellhub · Insecure Direct Object Reference

Affects shellhubSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.24.2 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.24.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade shellhub and shellhub-io/shellhub to 0.24.2.

Affected software

ProductAffectedFixed in
shellhub-ioshellhubAffected
  • <0.24.2
Fixed in
  • 0.24.2
GitHubshellhub-io/shellhubpkg:github/shellhub-io/shellhubOther threatsAffected
  • <0.24.2
Fixed in
  • 0.24.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ShellHub to version 0.24.2 or later, where this authorization bypass vulnerability is fixed. Since the vendor advisory indicates the issue is resolved in 0.24.2, applying this official fix is the recommended remediation. No additional mitigations are specified.

Description

CVE-2026-44424 is an authorization bypass vulnerability in shellhub versions prior to 0.24.2. The issue occurs because the API endpoint GET /api/devices/:uid returns full device metadata to any authenticated user without verifying device ownership within the caller's namespace. This allows an authenticated user with a valid JWT or API key to access device information from other tenants if they know or can guess the device UID. The vulnerability has a CVSS score of 6.5 (medium severity) and is fixed in version 0.24.2.

References

Community reviews

Loading reviews…