CVE-2026-44456: honojs hono · Uncontrolled Resource Consumption
Affects honojs honoSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 4.12.16 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.12.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade hono and honojs/hono to 4.12.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| honojshono | Affected
| Fixed in
|
npmhonojs/honopkg:npm/honojs/honoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to hono version 4.12.16 or later, where this vulnerability is fixed. Since the vendor advisory indicates the issue is resolved in 4.12.16, applying this official fix is the recommended remediation. Patch status is not explicitly stated beyond this fix, but upgrading is the definitive mitigation.
Description
Hono is a Web application framework that provides support for any JavaScript runtime. Prior to 4.12.16, bodyLimit() does not reliably enforce maxSize for requests without a usable Content-Length (e.g. Transfer-Encoding: chunked). Oversized requests can reach handlers and return 200 instead of 413. This vulnerability is fixed in 4.12.16.