Skip to main content
VulnerabilityPublished

CVE-2026-45033: github copilot-cli · Incorrect Behavior Order

Affects github copilot-cliSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.5 High : upgrade to 1.0.43 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.43
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade copilot-cli and github/copilot-cli to 1.0.43.

Affected software

ProductAffectedFixed in
githubcopilot-cliAffected
  • <1.0.43
Fixed in
  • 1.0.43
GitHubgithub/copilot-clipkg:github/github/copilot-cliOther threatsAffected
  • <1.0.43
Fixed in
  • 1.0.43

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitHub Copilot CLI to version 1.0.43 or later, where this vulnerability is fixed. Since the vendor advisory indicates the issue is resolved in 1.0.43, applying this official fix is the recommended remediation. No other mitigation or temporary workaround is provided in the available data.

Description

GitHub Copilot CLI versions prior to 1.0.43 contain a high-severity vulnerability (CVE-2026-45033) that allows arbitrary code execution. This occurs when a malicious bare git repository is nested inside a project directory, exploiting git's automatic bare repository discovery during directory traversal. The vulnerability leverages git configuration keys such as core.fsmonitor and others that can execute arbitrary shell commands during normal git operations. This issue is fixed in version 1.0.43.

References

Community reviews

Loading reviews…