Skip to main content
VulnerabilityPublished Updated

CVE-2026-44577: vercel next.js · Unthrottled Resource Allocation

Affects vercel next.jsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.9 Medium : upgrade to 16.2.5 or 15.5.16 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.2.5, 15.5.16
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade next.js and next to 16.2.5 or 15.5.16.

Affected software

ProductAffectedFixed in
vercelnext.jsAffected
  • >=16.0.0 <16.2.5
Fixed in
  • 16.2.5
vercelnext.jsAffected
  • >=10.0.0 <15.5.16
Fixed in
  • 15.5.16
npmnextpkg:npm/nextOther threatsAffected
  • >=10.0.0 <15.5.16
  • >=16.0.0 <16.2.5
Fixed in
  • 15.5.16
  • 16.2.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability is not applicable when using Vercel hosting, a custom image loader, or setting images.unoptimized to true. Users are advised to consider these configurations to mitigate the risk. Since no suitable mitigation meeting Red Hat's criteria is available, upgrading to fixed versions 15.5.16 or later and 16.2.5 or later when possible is recommended.

Description

Next.js is a React framework for building full-stack web applications. From 10.0.0 to before 15.5.16 and 16.2.5, when self-hosting Next.js with the default image loader, the Image Optimization API fetches local images entirely into memory without enforcing a maximum size limit. An attacker could cause out-of-memory conditions by requesting large local assets from the /_next/image endpoint that match the images.localPatterns configuration (by default, all patterns are allowed). This vulnerability is fixed in 15.5.16 and 16.2.5.

References

Community reviews

Loading reviews…