CVE-2026-45109: vercel next.js · Authentication Bypass Using an Alternate Path or Channel
Affects vercel next.jsSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.5 High : upgrade to 16.2.6 or 15.5.17 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.2.6, 15.5.17, 15.5.18
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade next.js to 16.2.6 or 15.5.17; vercel/next.js to 16.2.6 or 15.5.18.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vercelnext.js | Affected
| Fixed in
|
| vercelnext.js | Affected
| Fixed in
|
GitHubvercel/next.jspkg:github/vercel/next.jsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Next.js versions 15.5.18 and 16.2.6. Users should upgrade to these or later versions to remediate the vulnerability. According to the Red Hat advisory, no effective mitigation other than upgrading is currently available or meets their criteria for deployment and stability. Monitoring for vendor updates and applying official patches promptly is recommended.
Description
Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.18 and 16.2.6, it was found that the fix addressing CVE-2026-44575 did not apply to middleware.ts with Turbopack. This vulnerability is fixed in 15.5.18 and 16.2.6.
References
- github.com/vercel/next.js/security/advisories/GHSA-26hh-7cqf-hhc6 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-45109 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2477190 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-45109.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:40974 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:37272 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:34608 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:54435 (opens in a new tab)