Skip to main content
VulnerabilityPublished Updated

CVE-2026-44579: vercel next.js · Unthrottled Resource Allocation

Affects vercel next.jsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 16.2.5 or 15.5.16 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.2.5, 15.5.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade next.js and next to 16.2.5 or 15.5.16.

Affected software

ProductAffectedFixed in
vercelnext.jsAffected
  • >=16.0.0 <16.2.5
Fixed in
  • 16.2.5
vercelnext.jsAffected
  • >=15.0.0 <15.5.16
Fixed in
  • 15.5.16
npmnextpkg:npm/nextOther threatsAffected
  • <15.5.16
  • <16.2.5
Fixed in
  • 15.5.16
  • 16.2.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Next.js versions 15.5.16 and 16.2.5. Users should upgrade to these or later versions to remediate the vulnerability. According to the Red Hat advisory, no effective mitigation other than upgrading is currently available or meets their criteria for ease of use and applicability. Therefore, upgrading is the recommended remediation.

Description

Next.js is a React framework for building full-stack web applications. From to before 15.5.16 and 16.2.5, applications using Partial Prerendering through the Cache Components feature can be vulnerable to connection exhaustion through crafted POST requests to a server action. In affected configurations, a malicious request can trigger a request-body handling deadlock that leaves connections open for an extended period, consuming file descriptors and server capacity until legitimate users are denied service. This vulnerability is fixed in 15.5.16 and 16.2.5.

References

Community reviews

Loading reviews…