CVE-2026-44581: vercel next.js · Cross-site Scripting
Affects vercel next.jsSource CVE Database V5
Not known to be exploited · CVSS 4.7 Medium : upgrade to 16.2.5 or 15.5.16 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.2.5, 15.5.16
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade next.js and next to 16.2.5 or 15.5.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vercelnext.js | Affected
| Fixed in
|
| vercelnext.js | Affected
| Fixed in
|
npmnextpkg:npm/nextOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Next.js to version 15.5.16 or later in the 15.x series, or 16.2.5 or later in the 16.x series, where this vulnerability is fixed. There is no official vendor advisory provided here, but the fix is confirmed in the version ranges specified. Patch status is confirmed by the version information. No additional mitigation steps are indicated.
Description
Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.