Skip to main content
VulnerabilityPublished Updated

CVE-2026-44575: vercel next.js · Authentication Bypass Using an Alternate Path or Channel

Affects vercel next.jsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 16.2.5 or 15.5.16 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.5% chance of exploitation in 30 days – higher than 75% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.2.5, 15.5.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade next.js and vercel/next.js to 16.2.5 or 15.5.16.

Affected software

ProductAffectedFixed in
vercelnext.jsAffected
  • >=16.0.0 <16.2.5
Fixed in
  • 16.2.5
vercelnext.jsAffected
  • >=15.2.0 <15.5.16
Fixed in
  • 15.5.16
GitHubvercel/next.jspkg:github/vercel/next.jsOther threatsAffected
  • >=15.2.0 <15.5.16
  • >=16.0.0 <16.2.5
Fixed in
  • 15.5.16
  • 16.2.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability is fixed in Next.js versions 15.5.16 and 16.2.5. Users should upgrade to these or later versions to remediate the issue. Red Hat's advisory states that no effective mitigations currently meet their criteria for ease of use and applicability, so upgrading is the recommended course of action.

Description

Next.js is a React framework for building full-stack web applications. From 15.2.0 to before 15.5.16 and 16.2.5, App Router applications that rely on middleware or proxy-based checks for authorization can allow unauthorized access through transport-specific route variants used for segment prefetching. In affected configurations, specially crafted .rsc and segment-prefetch URLs can resolve to the same page without being matched by the intended middleware rule, which can allow protected content to be reached without the expected authorization check. This vulnerability is fixed in 15.5.16 and 16.2.5.

References

Community reviews

Loading reviews…