CVE-2026-44573: vercel next.js · Incorrect Authorization
Affects vercel next.jsSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 16.2.5 or 15.5.16 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.7% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.2.5, 15.5.16
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade next.js and vercel/next.js to 16.2.5 or 15.5.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vercelnext.js | Affected
| Fixed in
|
| vercelnext.js | Affected
| Fixed in
|
GitHubvercel/next.jspkg:github/vercel/next.jsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The vulnerability is fixed in Next.js versions 15.5.16 and 16.2.5. Users should upgrade to these or later versions to remediate the issue. According to the Red Hat advisory, no effective mitigation currently meets their criteria for ease of use, applicability, and stability. Therefore, upgrading to a fixed version is the recommended and primary remediation step.
Description
Next.js is a React framework for building full-stack web applications. From 12.2.0 to before 15.5.16 and 16.2.5, Applications using the Pages Router with i18n configured and middleware/proxy-based authorization can allow unauthorized access to protected page data through locale-less /_next/data/<buildId>/<page>.json requests. In affected configurations, middleware does not run for the unprefixed data route, allowing an attacker to retrieve SSR JSON for protected pages without passing the intended authorization checks. This vulnerability is fixed in 15.5.16 and 16.2.5.
References
- github.com/vercel/next.js/security/advisories/GHSA-36qx-fr4f-26g5 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-44573 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2477199 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44573.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:40974 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:37272 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:34608 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:54435 (opens in a new tab)