CVE-2026-44574: vercel next.js · Authentication Bypass Using an Alternate Path or Channel
Affects vercel next.jsSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 16.2.5 or 15.5.16 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.2.5, 15.5.16
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade next.js and next to 16.2.5 or 15.5.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vercelnext.js | Affected
| Fixed in
|
| vercelnext.js | Affected
| Fixed in
|
npmnextpkg:npm/nextOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Red Hat currently states that no mitigation is available or that existing options do not meet their criteria for ease of use, applicability, or stability. Users are advised to upgrade to Next.js versions 15.5.16 or 16.2.5 or later where the vulnerability is fixed. If you cannot patch yet, carefully review middleware protections and consider restricting access through alternative controls if feasible.
Description
Next.js is a React framework for building full-stack web applications. From 15.4.0 to before 15.5.16 and 16.2.5, applications that rely on middleware to protect dynamic routes can be vulnerable to authorization bypass. In affected deployments, specially crafted query parameters can alter the dynamic route value seen by the page while leaving the visible path unchanged, which can allow protected content to be rendered without passing the expected middleware check. This vulnerability is fixed in 15.5.16 and 16.2.5.
References
- github.com/vercel/next.js/security/advisories/GHSA-492v-c6pp-mqqv (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-44574 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2477207 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-44574.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:40974 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:37272 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:34608 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:54435 (opens in a new tab)