CVE-2026-44664: NaturalIntelligence fast-xml-builder · XML Injection
Affects NaturalIntelligence fast-xml-builderSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 6.1 Medium · fixed in 1.1.6 : update NaturalIntelligence fast-xml-builder when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.1.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| NaturalIntelligencefast-xml-builder | Affected
| Fixed in– |
npmfast-xml-builderpkg:npm/fast-xml-builderOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade fast-xml-builder to version 1.1.6 or later where this vulnerability is fixed. Patch status is not explicitly confirmed via vendor advisory, but the description states the issue is fixed in 1.1.6. Until upgrading, avoid processing untrusted input with version 1.1.5 to mitigate risk.
Description
fast-xml-builder builds XML from JSON. In 1.1.5, the fix for CVE-2026-41650 in fast-xml-parser sanitizes -- sequences in XML comment content using .replace(/--/g, '- -'). This skip the values containing three consecutive dashes (e.g., --->...), allowing an attacker to break out of an XML comment and inject arbitrary XML/HTML content. This vulnerability is fixed in 1.1.6.