Skip to main content
VulnerabilityPublished

CVE-2026-44462: zed · Incomplete List of Disallowed Inputs

Affects zedSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.4 Medium : upgrade to 0.229.0 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.229.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade zed and zed-industries/zed to 0.229.0.

Affected software

ProductAffectedFixed in
zed-industrieszedAffected
  • <0.229.0
Fixed in
  • 0.229.0
GitHubzed-industries/zedpkg:github/zed-industries/zedOther threatsAffected
  • <0.229.0
Fixed in
  • 0.229.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to zed version 0.229.0 or later, where this vulnerability is fixed. Since the vulnerability is resolved in this version, applying this official fix is the recommended remediation. Patch status is confirmed by the vendor's versioning information.

Description

Zed, a code editor, had a vulnerability in versions prior to 0.229.0 where its terminal tool permission system could be bypassed using bash variable expansion chaining (${var@P}). This allowed arbitrary command execution under an allowlisted command prefix. The issue is classified under CWE-184 (Incomplete List of Disallowed Inputs). The vulnerability has a CVSS score of 6.4, indicating medium severity. A fix for this vulnerability was introduced in version 0.229.0.

References

Community reviews

Loading reviews…