Skip to main content
VulnerabilityPublished

CVE-2026-44466: zed · OS Command Injection

Affects zedSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 0.229.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.229.0
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade zed and zed-industries/zed to 0.229.0.

Affected software

ProductAffectedFixed in
zed-industrieszedAffected
  • <0.229.0
Fixed in
  • 0.229.0
GitHubzed-industries/zedpkg:github/zed-industries/zedOther threatsAffected
  • <0.229.0
Fixed in
  • 0.229.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Zed to version 0.229.0 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated. Patch status is confirmed by the vendor stating the issue is fixed in 0.229.0.

Description

Zed, a code editor, contains an OS command injection vulnerability (CVE-2026-44466) in versions prior to 0.229.0. The issue arises because the terminal tool permission system can be bypassed using bash arithmetic expansion $((... )), allowing execution of arbitrary commands nested inside an allowlisted command such as echo. This vulnerability has a high severity with a CVSS score of 8.6. The vulnerability is fixed in version 0.229.0.

References

Community reviews

Loading reviews…