CVE-2026-44945: SUSE Rancher · Confused Deputy
Affects SUSE RancherSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical · fixed in 2.14.2 : patch SUSE Rancher as a priority.
Data as of 3 Nov 2026, 10:58 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.14.2, 2.13.8, 2.12.12 +2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 5 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade Rancher to 2.14.2, 2.13.8, 2.12.12 or 2.11.16; Rancher to 2.14.4, 2.13.8, 2.12.12 or 2.11.16.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SUSERancher | Affected
| Fixed in
|
GitHubRancherpkg:github/RancherOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict authenticated user roles carefully and monitor for suspicious privilege escalations. Avoid granting default global user roles broadly. Follow SUSE Rancher's official advisories for updates and patches.
Description
CVE-2026-44945 is a critical privilege escalation vulnerability in SUSE Rancher's impersonation middleware. An authenticated user with the default global user role can escalate privileges to gain full administrative access to the Rancher control plane and all downstream clusters it manages. The vulnerability affects Rancher versions from 2.11.0 before 2.11.16, 2.12.0 before 2.12.12, 2.13.0 before 2.13.8, and 2.14.0 before 2.14.2.