CVE-2026-44977: countly-server · Cross-site Scripting
Affects countly-serverSource CVE Database V5
Not known to be exploited · CVSS 9.0 Critical : upgrade to 25.03.44 or 24.05.50 as a priority.
Data as of 26 Oct 2026, 14:18 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 25.03.44, 24.05.50
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade countly-server and countly/countly-server to 25.03.44 or 24.05.50.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Countlycountly-server | Affected
| Fixed in
|
| Countlycountly-server | Affected
| Fixed in
|
GitHubcountly/countly-serverpkg:github/countly/countly-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in countly-server versions 24.05.50 and 25.03.44. Users should upgrade to these versions or later to remediate the issue. No additional mitigation is required once these updates are applied.
Description
CVE-2026-44977 is a critical cross-site scripting (XSS) vulnerability in the Countly countly-server product analytics solution. The flaw exists in the star-rating plugin's API and frontend components prior to versions 24.05.50 and 25.03.44. It allows a non-global application administrator to upload attacker-controlled active content with a trusted MIME type, which is then served with the attacker-influenced Content-Type. When a global administrator previews this content, the malicious payload executes in the Countly origin, exposing authenticated session tokens including auth_token and csrf_token. This vulnerability has a CVSS score of 9.0 and is fixed in the specified versions.
References
- github.com/Countly/countly-server/security/advisories/GHSA-jqp4-p86c-phxc (opens in a new tab)
- github.com/Countly/countly-server/commit/ae899f37bc6d70c1b44859756ce80a204ae72631 (opens in a new tab)
- github.com/Countly/countly-server/commit/fcb16c808c0fdb6dc99fe9c66de7fc560b3a9c41 (opens in a new tab)
- github.com/Countly/countly-server/releases/tag/24.05.50 (opens in a new tab)
- github.com/Countly/countly-server/releases/tag/25.03.44 (opens in a new tab)