CVE-2026-87803: countly-server · Countly DBViewer authorization bypass via nested aggregation stage poisoning
Affects countly-serverSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 25.03.53-LTS soon.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Limited control over the software or limited information exposure
CISA SSVC assessment, 2026-09-10.
- Patch
- Available – fixed in 25.03.53-LTS
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade countly-server to 25.03.53-LTS.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Countlycountly-server | Affected
| Fixed in
|
AI-suggested
A fixed version 25.03.53-LTS of countly-server is available that addresses this authorization bypass vulnerability. Users should upgrade to this version or later to remediate the issue. No additional mitigations are indicated by the vendor advisory.
Description
CVE-2026-87803 is an authorization bypass vulnerability in Countly Server's DBViewer component. It arises from improper detection of nested aggregation stages in the aggregation stage sanitizer, allowing non-admin users with read permission to inject forbidden MongoDB operators. This enables unauthorized cross-collection data access, including sensitive information like password-reset tokens, potentially leading to account takeover. The vulnerability affects versions prior to 25.03.53-LTS and has a CVSS 4.0 score of 7.1 (high severity).