Skip to main content
VulnerabilityPublished

CVE-2026-45081: frappe hrms · Incorrect Authorization

Affects frappe hrmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 16.5.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 9% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.5.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade hrms and frappe/hrms to 16.5.0.

Affected software

ProductAffectedFixed in
frappehrmsAffected
  • <16.5.0
Fixed in
  • 16.5.0
GitHubfrappe/hrmspkg:github/frappe/hrmsOther threatsAffected
  • <16.5.0
Fixed in
  • 16.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Frappe HRMS to version 16.5.0 or later, where the authorization checks have been corrected. Since this is an open-source product and not a cloud service, applying the official patch by updating the software is required. Patch status is confirmed fixed in version 16.5.0.

Description

Frappe HR is an open-source human resources management solution (HRMS). Prior to 16.5.0, authenticated employees could access other employees’ leave details due to improper authorization checks. This vulnerability is fixed in 16.5.0.

References

Community reviews

Loading reviews…