CVE-2026-45283: nextcloud security-advisories · Improper Authentication
Affects nextcloud security-advisoriesSource CVE Database V5
Not known to be exploited · CVSS 6.3 Medium : upgrade to 33.0.1 or 32.0.2 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 33.0.1, 32.0.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 1 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade security-advisories and nextcloud/files_lock to 33.0.1 or 32.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nextcloudsecurity-advisories | Affected
| Fixed in
|
| nextcloudsecurity-advisories | Affected
| Fixed in
|
GitHubnextcloud/files_lockpkg:github/nextcloud/files_lockOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrading Nextcloud Server to version 32.0.2 or 33.0.1, or Nextcloud Enterprise Server to version 31.0.14.4, 32.0.2, or 33.0.1 is recommended to remediate this vulnerability. Patch status is not explicitly confirmed in the advisory, but the vendor recommends these upgrades as fixes. No alternative mitigations or temporary workarounds are provided.
Description
Nextcloud Server versions 32.0.0 to before 32.0.2 and 33.0.0 to before 33.0.1 contain an improper authentication vulnerability in the files_lock app. This flaw allows authenticated users to lock or unlock files owned by other users by exploiting absolute WebDAV paths.