Skip to main content
VulnerabilityPublished Updated

CVE-2026-46087: Linux kernel · Memory Leak

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 7.0.0-1010.10 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 13:47 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 +1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Linux kernel to 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 or 7.0.0-27.27.

Affected software

ProductAffectedFixed in
linux-hwe-edgeAffected
  • <7.0.0-27.27
  • <7.0.0-1008.8
  • <7.0.0-1010.10
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-27.27
  • 7.0.0-1008.8
  • 7.0.0-1010.10
  • 7.0.0-1009.9

AI-suggested

An official patch is available from the vendor. Users should update their Linux kernel packages to the fixed versions listed in the Ubuntu security advisory USN-8488-1 and reboot the system to apply the changes. Due to an ABI change, recompilation and reinstallation of all third-party kernel modules may be necessary. No additional mitigations are required beyond applying the official update.

Description

A memory leak vulnerability (CVE-2026-46087) in the Linux kernel's DAMON subsystem was fixed. The issue occurs when damon_start() fails in damon_stat_start(), causing the allocated DAMON context to leak and the global pointer to become stale. This can lead to permanent memory leakage. The vulnerability has a medium severity with a CVSS score of 5.5 and impacts availability. A patch is available and included in Linux kernel updates for multiple Ubuntu HWE edge versions. Users should update and reboot to apply the fix.

References

Community reviews

Loading reviews…