Skip to main content
VulnerabilityPublished Updated

CVE-2026-4610: ProfileGrid (WordPress plugin) · Cross-site Scripting

Affects ProfileGrid (WordPress plugin)Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.4 Medium · fixed in 5.9.8.5 : update ProfileGrid (WordPress plugin) when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
6.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.9.8.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
metagaussProfileGrid – User Profiles, Groups and CommunitiesAffected
  • <=5.9.9.2
Fixed in–

AI-suggested

Since a partial patch was applied in version 5.9.8.5 but versions up to 5.9.9.2 remain vulnerable, users should monitor for an official fix from the vendor. Until then, restrict Subscriber-level access where possible and consider disabling or replacing the plugin if feasible.

Description

The ProfileGrid – User Profiles, Groups and Communities plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'pm_author_message' parameter in the pm_send_message_to_author function in all versions up to, and including, 5.9.9.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 5.9.8.5.

References

Community reviews

Loading reviews…