Skip to main content
VulnerabilityPublished

CVE-2026-46484: tale headplane · Path Traversal

Affects tale headplaneSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 0.7.0-beta.3 or 0.6.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.7.0-beta.3, 0.6.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade headplane to 0.7.0-beta.3 or 0.6.3; tale/headplane to 0.6.3.

Affected software

ProductAffectedFixed in
taleheadplaneAffected
  • >=0.7.0-beta.1 <0.7.0-beta.3
Fixed in
  • 0.7.0-beta.3
taleheadplaneAffected
  • <0.6.3
Fixed in
  • 0.6.3
GitHubtale/headplanepkg:github/tale/headplaneOther threatsAffected
  • <0.6.3
Fixed in
  • 0.6.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Headplane to version 0.6.3 or later, or 0.7.0-beta.3 or later, where this vulnerability has been patched. No other mitigation guidance is provided. Patch status is not explicitly confirmed by a vendor advisory but the description states the issue is fixed in these versions.

Description

Headplane versions prior to 0.6.3 and 0.7.0-beta.3 contain a path traversal vulnerability in the Headscale API client used for node and user rename operations. This vulnerability allows improper limitation of pathnames, leading to authorization bypass. The issue has been patched in versions 0.6.3 and 0.7.0-beta.3.

References

Community reviews

Loading reviews…