Skip to main content
VulnerabilityPublished

CVE-2026-47248: parse-server · Generation of Error Message Containing Sensitive Information

Affects parse-serverSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.9 Medium : upgrade to 9.9.1-alpha.2 or 8.6.78 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.9.1-alpha.2, 8.6.78
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade parse-server to 9.9.1-alpha.2 or 8.6.78; parse-community/parse-server to 8.6.78.

Affected software

ProductAffectedFixed in
parse-communityparse-serverAffected
  • >=9.0.0 <9.9.1-alpha.2
Fixed in
  • 9.9.1-alpha.2
parse-communityparse-serverAffected
  • <8.6.78
Fixed in
  • 8.6.78
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threatsAffected
  • <8.6.78
  • =9.9.1-alpha.2
Fixed in
  • 8.6.78

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability has been patched in parse-server versions 8.6.78 and 9.9.1-alpha.2. Users should upgrade to at least version 8.6.78 or later to remediate this issue. No additional mitigations are specified or required once patched.

Description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.78 and 9.9.1-alpha.2, Parse Server's GraphQL endpoint discloses schema metadata to unauthenticated callers through Did you mean ...? suggestions embedded in GraphQL validation-error messages. An unauthenticated caller who knows only the public application id can iteratively send malformed queries to reconstruct class names, field names, argument names, mutation names, and input-object fields. This issue has been patched in versions 8.6.78 and 9.9.1-alpha.2.

References

Community reviews

Loading reviews…