Skip to main content
VulnerabilityPublished Updated

CVE-2026-48773: sysown proxysql · Out-of-bounds Write

Affects sysown proxysqlSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical : upgrade to 3.0.9 as a priority.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade sysown proxysql to 3.0.9.

Affected software

ProductAffectedFixed in
sysownproxysqlAffected
  • >=2.0.18 <3.0.9
Fixed in
  • 3.0.9
GitHubsysown/proxysqlpkg:github/sysown/proxysqlOther threatsAffected
  • >=2.0.18 <=3.0.8
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in ProxySQL version 3.0.9. Users should upgrade to version 3.0.9 or later to remediate this vulnerability. No vendor advisory content was provided to indicate alternative mitigations or temporary fixes. Until patched, restricting access to ProxySQL instances from untrusted networks may reduce exposure.

Description

ProxySQL is a proxy for MySQL and its forks, as well as PostgreSQL. Versions 2.0.18 through 3.0.8 have a pre-authentication heap memory corruption vulnerability in the MySQL and PostgreSQL protocol first-read paths. A remote unauthenticated client can declare an oversized first packet length, and ProxySQL passes that attacker-controlled length directly to `recv()` while writing into a fixed 32 KB input queue. Version 3.0.9 patches the issue.

References

Community reviews

Loading reviews…