Skip to main content
VulnerabilityPublished

CVE-2026-49157: Apache ActiveMQ · Incorrect Default Permissions

Affects Apache ActiveMQSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 6.2.6 or 5.19.7 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.2.6, 5.19.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Apache ActiveMQ and org.apache.activemq/activemq and Apache Software Foundation/org.apache.activemq:apache-activemq to 6.2.6 or 5.19.7.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache ActiveMQAffected
  • >=6.0.0 <6.2.6
Fixed in
  • 6.2.6
Apache Software FoundationApache ActiveMQAffected
  • <5.19.7
Fixed in
  • 5.19.7
Mavenorg.apache.activemq/activemqpkg:maven/org.apache.activemq/activemqOther threatsAffected
  • <5.19.7
  • >=6.0.0 <6.2.6
  • =6.0.0
Fixed in
  • 5.19.7
  • 6.2.6
MavenApache Software Foundation/org.apache.activemq:apache-activemqpkg:maven/Apache Software Foundation/org.apache.activemq:apache-activemqOther threatsAffected
  • <5.19.7
  • >=6.0.0 <6.2.6
Fixed in
  • 5.19.7
  • 6.2.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache ActiveMQ to version 5.19.7 or 6.2.6 or later, where the Jolokia authorization settings have been corrected to restrict management operations to admin users only. Patch status is confirmed by the vendor advisory recommending these versions. No additional mitigations are specified.

Description

Apache ActiveMQ versions before 5.19.7 and from 6.0.0 before 6.2.6 have an incorrect default permissions vulnerability in the Jolokia authorization settings. This misconfiguration allows low-privilege web-login users to perform broker management operations intended only for administrators, such as adding or removing queues. The issue is addressed in versions 5.19.7 and 6.2.6.

References

Community reviews

Loading reviews…