Skip to main content
VulnerabilityPublished Updated

CVE-2026-90560: luben zstd-jni · Out-of-bounds Read

Affects luben zstd-jniSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 1.5.7-14 soon.

Data as of 27 Oct 2026, 17:11 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 49% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.5.7-14
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade zstd-jni and luben/zstd-jni to 1.5.7-14.

Affected software

ProductAffectedFixed in
lubenzstd-jniAffected
  • >=1.2.0 <1.5.7-14
Fixed in
  • 1.5.7-14
Mavenluben/zstd-jnipkg:maven/luben/zstd-jniOther threatsAffected
  • >=1.2.0 <1.5.7-14
Fixed in
  • 1.5.7-14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should monitor for an official fix or update to zstd-jni beyond version 1.5.7-13. If you cannot patch yet, avoid processing untrusted input with vulnerable versions to mitigate risk.

Description

An out-of-bounds read vulnerability exists in the ZstdDictDecompress constructor of zstd-jni versions 1.2.0 through 1.5.7-13. This occurs because the offset and length parameters are not validated against the dictionary array bounds, allowing attackers to read memory beyond the intended array. This can potentially cause the Java Virtual Machine (JVM) to terminate unexpectedly.

References

Community reviews

Loading reviews…