CVE-2026-49260: pontedilana php-weasyprint · OS Command Injection
Affects pontedilana php-weasyprintSource CVE Database V5
Not known to be exploited · CVSS 8.2 High : upgrade to 2.5.1 soon.
Data as of 1 Nov 2026, 22:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.5.1
CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade php-weasyprint and pontedilana/php-weasyprint to 2.5.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| pontedilanaphp-weasyprint | Affected
| Fixed in
|
Packagistpontedilana/php-weasyprintpkg:composer/pontedilana/php-weasyprintOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to php-weasyprint version 2.5.1 or later, which contains a patch for this vulnerability. Until upgraded, ensure that the binary path configuration cannot be influenced by untrusted sources. Patch status is not explicitly stated as 'official-fix' but the vendor has released version 2.5.1 containing the fix, so upgrading is the recommended remediation.
Description
PhpWeasyPrint is a PHP library allowing PDF generation from a URL or an HTML page. Prior to version 2.5.1, `pontedilana/php-weasyprint` builds the shell command for WeasyPrint by passing the binary path through `escapeshellarg()` first and then checking the *quoted* result with `is_executable()`. On POSIX `escapeshellarg('/usr/local/bin/weasyprint')` returns `'/usr/local/bin/weasyprint'` with the single-quote characters as part of the string, so `is_executable()` looks for a file whose actual name includes those quotes. That file never exists, the "safe" branch is dead code, and the raw `$binary` string (set via the constructor or `setBinary()`) flows directly into `Symfony\Component\Process\Process::fromShellCommandline()`. Any deployment whose binary path is sourced from configuration, an environment variable, or a per-tenant setting reaches a shell-command-injection sink. The library is documented as a one-to-one substitute for KnpLabs/snappy and inherited the exact pre-fix codepath KnpLabs patched in GHSA-vpr4-p6fq-85jc. PhpWeasyPrint version 2.5.1 contains a patch for the issue.
References
- github.com/pontedilana/php-weasyprint/security/advisories/GHSA-f5gc-qxf8-mh9g (opens in a new tab)
- github.com/KnpLabs/snappy/security/advisories/GHSA-vpr4-p6fq-85jc (opens in a new tab)
- github.com/pontedilana/php-weasyprint/commit/9e86a2b317237fc5728f712f5037164530117f7e (opens in a new tab)
- github.com/pontedilana/php-weasyprint/releases/tag/2.5.1 (opens in a new tab)