CVE-2026-49453: laurent22 joplin · Improper Input Validation
Affects laurent22 joplinSource CVE Database V5
Not known to be exploited · CVSS 7.0 High : upgrade to 3.7.2 or 3.6.15 soon.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.7.2, 3.6.15
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 21 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade joplin and laurent22/joplin to 3.7.2 or 3.6.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| laurent22joplin | Affected
| Fixed in
|
| laurent22joplin | Affected
| Fixed in
|
GitHublaurent22/joplinpkg:github/laurent22/joplinOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in Joplin versions 3.6.15 and 3.7.2. Users should upgrade to at least these versions to remediate the issue. No additional mitigation is required once updated.
Description
Joplin before versions 3.6.15 and 3.7.2 contains an improper input validation vulnerability where synchronized resource metadata fields can include directory traversal characters. This allows an attacker with write access to a sync target or shared notebook to write files outside the intended resource directory without user interaction. The issue is fixed in versions 3.6.15 and 3.7.2.
References
- github.com/laurent22/joplin/security/advisories/GHSA-r24r-gp6h-cwgf (opens in a new tab)
- github.com/laurent22/joplin/pull/15540 (opens in a new tab)
- github.com/laurent22/joplin/pull/15672 (opens in a new tab)
- github.com/laurent22/joplin/commit/18e0b08c282c89ae51612c4eff67af2a45ff5163 (opens in a new tab)
- github.com/laurent22/joplin/commit/50518073740c4501058e366300b42c2f1925cb05 (opens in a new tab)