Skip to main content
VulnerabilityPublished

CVE-2026-59816: laurent22 joplin · Path Traversal

Affects laurent22 joplinSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.3 Medium : upgrade to 3.7.7 when convenient.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.7.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade joplin and laurent22/joplin to 3.7.7.

Affected software

ProductAffectedFixed in
laurent22joplinAffected
  • <3.7.7
Fixed in
  • 3.7.7
GitHublaurent22/joplinpkg:github/laurent22/joplinOther threatsAffected
  • <3.7.7
Fixed in
  • 3.7.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Joplin Server to version 3.7.7 or later, where this path traversal vulnerability is fixed. No additional mitigation is required once the server is updated.

Description

Joplin Server versions prior to 3.7.7 with transcription enabled are vulnerable to a path traversal issue. Authenticated users can manipulate the transcription job ID to escape the intended directory path, causing the server to proxy requests to unintended backend endpoints. This may expose internal administrative, health, or configuration data. The vulnerability is fixed in version 3.7.7.

References

Community reviews

Loading reviews…