Skip to main content
VulnerabilityPublished

CVE-2026-4946: NSA Ghidra · OS Command Injection

Affects NSA GhidraSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 12.0.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 12.0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Ghidra and nationalsecurityagency/ghidra to 12.0.3.

Affected software

ProductAffectedFixed in
NSAGhidraAffected
  • <12.0.3
Fixed in
  • 12.0.3
GitHubnationalsecurityagency/ghidrapkg:github/nationalsecurityagency/ghidraOther threatsAffected
  • <12.0.3
Fixed in
  • 12.0.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Analysts should avoid opening or interacting with untrusted or suspicious binaries in Ghidra versions prior to 12.0.3. If you cannot patch yet, exercising caution with auto-analysis results and disabling or restricting clickable annotations may reduce risk.

Description

CVE-2026-4946 is a high-severity OS command injection vulnerability in NSA Ghidra versions prior to 12.0.3. The issue arises because Ghidra improperly processes @execute annotations embedded in automatically extracted binary data during auto-analysis. This flaw allows a crafted binary to display clickable text in the UI that, when clicked by an analyst, executes arbitrary commands on the analyst's machine. The vulnerability affects local users interacting with the UI and requires user interaction to trigger.

References

Community reviews

Loading reviews…