Skip to main content
VulnerabilityPublished Updated

CVE-2026-50628: Apache CXF · Improper Input Validation

Affects Apache CXFSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.8 Critical · fixed in 4.2.2 : patch Apache CXF as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.2, 4.1.7, 3.6.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache to 4.2.2, 4.1.7 or 3.6.12.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache CXFAffected
  • >=4.2.0 <4.2.2
Fixed in
  • 4.2.2
Apache Software FoundationApache CXFAffected
  • >=4.0.0 <4.1.7
Fixed in
  • 4.1.7
Apache Software FoundationApache CXFAffected
  • <3.6.12
Fixed in
  • 3.6.12
MavenApache Software Foundation/org.apache.cxf:cxf-rt-rs-security-oauth2pkg:maven/Apache Software Foundation/org.apache.cxf:cxf-rt-rs-security-oauth2Other threatsAffected
  • >=4.2.0 <4.2.2
  • >=4.0.0 <4.1.7
  • <3.6.12
Fixed in
  • 4.2.2
  • 4.1.7
  • 3.6.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache CXF versions 4.2.2, 4.1.7, and 3.6.12. Users are strongly recommended to upgrade to these versions to remediate the vulnerability. No other effective mitigation is currently available or meets vendor criteria for ease of use and applicability. Red Hat advises applying the update as soon as possible.

Description

A logic error in OAuthRequestFilter rejects legitimate requests originating from the bound IP address, while blindly allowing requests from any other IP address. Enabling this security feature inadvertently creates an inverse security check. Users are recommended to upgrade to versions 4.2.2 or 4.1.7 or 3.6.12, which fixes this issue.

References

Community reviews

Loading reviews…