Skip to main content
VulnerabilityPublished Updated

CVE-2026-52904: Linux kernel · drm/nouveau: fix nvkm_device leak on aperture removal failure

Affects Linux kernelSource GCVE Database

0

Not known to be exploited · CVSS 5.5 Medium · fixed in 7.0.0-1010.10 : update Linux kernel when convenient.

Data as of 26 Oct 2026, 17:16 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 +1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade Linux kernel to 7.0.0-1010.10, 7.0.0-1009.9, 7.0.0-1008.8 or 7.0.0-27.27.

Affected software

ProductAffectedFixed in
linux-hwe-edgeAffected
  • <7.0.0-27.27
  • <7.0.0-1008.8
  • <7.0.0-1010.10
  • <7.0.0-1009.9
Fixed in
  • 7.0.0-27.27
  • 7.0.0-1008.8
  • 7.0.0-1010.10
  • 7.0.0-1009.9

AI-suggested

An official patch is available and included in updated Linux kernel packages for affected Ubuntu releases. Users should apply the kernel updates and reboot their systems to ensure the fix is applied. Due to an ABI change, recompilation and reinstallation of third-party kernel modules may be required. No additional mitigation is necessary beyond applying the vendor-provided updates.

Description

A memory leak vulnerability was identified and fixed in the Linux kernel's drm/nouveau GPU driver subsystem. The issue occurs when aperture_remove_conflicting_pci_devices() fails during device probing, causing an allocated nvkm_device not to be properly released, resulting in resource leakage. This flaw was introduced by a change in error handling that omitted a necessary cleanup step. The vulnerability has a CVSS score of 5.5 with low severity, indicating limited impact on confidentiality and integrity but high impact on availability due to resource exhaustion. A patch is available and included in Linux kernel updates for multiple Ubuntu 26.04 LTS and related releases. Users are advised to update and reboot to apply the fix.

References

Community reviews

Loading reviews…