Skip to main content
VulnerabilityPublished Updated

CVE-2026-53430: grpc · Data Amplification

Affects grpcSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.0.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.0, 1afbab9d57d2a3e16ca9c62ffa4923338ea96cfc
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade grpc to 1.0.0; grpc to 1afbab9d57d2a3e16ca9c62ffa4923338ea96cfc.

Affected software

ProductAffectedFixed in
elixir-grpcgrpcAffected
  • >=0.4.0 <1.0.0
Fixed in
  • 1.0.0
elixir-grpcgrpcAffected
  • ≥ beae6800fc8baf126f3fe7107d86a50e105275ba, < 1afbab9d57d2a3e16ca9c62ffa4923338ea96cfc
Fixed in
  • 1afbab9d57d2a3e16ca9c62ffa4923338ea96cfc
Hexgrpcpkg:hex/grpcOther threatsAffected
  • >=0.4.0 <1.0.0
Fixed in
  • 1.0.0

CPE configurations (1)

  • cpe:2.3:a:elixir-grpc:grpc:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, consider implementing external protections such as limiting incoming message sizes at the network level or disabling gzip compression if feasible.

Description

A high severity vulnerability in elixir-grpc grpc (versions from 0.4.0 before 1.0.0) allows unauthenticated remote attackers to cause a denial of service via a gzip decompression bomb. The issue arises because the grpc gzip decompressor calls :zlib.gunzip/1 directly on attacker-controlled data without limiting decompressed size or checking compression ratio, leading to excessive memory allocation and potential out-of-memory crashes.

References

Community reviews

Loading reviews…