Skip to main content
VulnerabilityPublished

CVE-2026-53753: unclecode crawl4ai · Code Injection

Affects unclecode crawl4aiSource CVE Database V5

0
Compare

Not known to be exploited · public detection template (Nuclei) · CVSS 9.8 Critical : upgrade to 0.8.7 as a priority.

Data as of 5 Nov 2026, 23:24 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.9% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.8.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade crawl4ai and unclecode/crawl4ai to 0.8.7.

Affected software

ProductAffectedFixed in
unclecodecrawl4aiAffected
  • <0.8.7
Fixed in
  • 0.8.7
GitHubunclecode/crawl4aipkg:github/unclecode/crawl4aiOther threatsAffected
  • <0.8.7
Fixed in
  • 0.8.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade crawl4ai to version 0.8.7 or later, where this vulnerability is fixed. No other mitigations are indicated or required as the fix addresses the root cause.

Description

Crawl4AI is an open-source LLM friendly web crawler & scraper. Prior to 0.8.7, the _safe_eval_expression() function in the computed fields feature uses an AST validator that only blocks attributes starting with underscore. Python generator and frame object attributes (gi_frame, f_back, f_builtins) do NOT start with underscore, enabling a complete sandbox escape to achieve arbitrary code execution. The attack requires no authentication (JWT disabled by default) and is triggered via POST /crawl with a crafted extraction schema. This vulnerability is fixed in 0.8.7.

References

Community reviews

Loading reviews…