Skip to main content
VulnerabilityPublished

CVE-2026-54182: Laravel-Backpack CRUD · Improper Input Validation

Affects Laravel-Backpack CRUDSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High · fixed in 7.0.36 : patch Laravel-Backpack CRUD soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.0.36, 6.8.13, 5.6.2 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade CRUD and laravel-backpack/CRUD to 7.0.36, 6.8.13, 5.6.2 or 4.1.70.

Affected software

ProductAffectedFixed in
Laravel-BackpackCRUDAffected
  • >=7.0.0 <7.0.36
Fixed in
  • 7.0.36
Laravel-BackpackCRUDAffected
  • >=6.0.0 <6.8.13
Fixed in
  • 6.8.13
Laravel-BackpackCRUDAffected
  • >=5.0.0 <5.6.2
Fixed in
  • 5.6.2
Laravel-BackpackCRUDAffected
  • <4.1.70
Fixed in
  • 4.1.70
GitHublaravel-backpack/CRUDpkg:github/laravel-backpack/CRUDOther threatsAffected
  • <4.1.70
  • >=5.0.0 <5.6.2
  • >=6.0.0 <6.8.13
  • >=7.0.0 <7.0.36
Fixed in
  • 4.1.70
  • 5.6.2
  • 6.8.13
  • 7.0.36

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Laravel-Backpack CRUD to version 4.1.70, 5.6.2, 6.8.13, or 7.0.36 or later where this issue is fixed. Until patched, relying solely on reverse-proxy Host validation or disabling exec() in PHP configurations is insufficient to fully mitigate the risk. Applying the official fixes is the recommended remediation.

Description

backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. Prior to 4.1.70, 5.6.2, 6.8.13, and 7.0.36, Backpack\CRUD\Stats::makeCurlRequest in src/Stats.php is reached from BackpackServiceProvider::boot() and constructs a shell command with a URL influenced by the HTTP Host header, which it passes to exec() without adequate shell neutralization. An unauthenticated attacker whose malformed Host value reaches PHP can inject operating-system commands when exec() and curl are available and the 1-in-100 random gate is reached. Repeated requests can reach the random gate. Successful exploitation executes commands as the web-server user, exposing environment secrets, files, and reachable services and permitting data modification or service disruption. Common reverse-proxy Host validation and hardened PHP configurations that disable exec() reduce reachability but do not correct the vulnerable construction. This issue is fixed in versions 4.1.70, 5.6.2, 6.8.13, and 7.0.36.

References

Community reviews

Loading reviews…