CVE-2026-54185: Cornerstone (WordPress plugin) · SQL Injection
Affects Cornerstone (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.5 High : upgrade to 7.8.8 soon.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.8.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Cornerstone (WordPress plugin) to 7.8.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| THEMECOCornerstone | Affected
| Fixed in
|
AI-suggested
If you cannot patch yet, users should exercise caution with the Subscriber functionality and consider applying any available workarounds or temporary mitigations recommended by THEMECO.
Description
CVE-2026-54185 is a high severity SQL Injection vulnerability affecting THEMECO Cornerstone versions prior to 7.8.8. The flaw allows improper neutralization of special elements in SQL commands, specifically in the Subscriber functionality. This vulnerability can be exploited remotely with low attack complexity and requires low privileges but no user interaction. It impacts confidentiality with high severity and availability with low severity, while integrity is not affected.