Skip to main content
VulnerabilityPublished

CVE-2026-5423: neo4j graphql · Authentication Bypass by Assumed-Immutable Data

Affects neo4j graphqlSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.2 High : upgrade to 7.5.6 or 5.12.14 soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.5.6, 5.12.14
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade graphql and @neo4j/graphql to 7.5.6 or 5.12.14.

Affected software

ProductAffectedFixed in
neo4jgraphqlAffected
  • >=7.0.0 <7.5.6
  • >=5.0.0 <5.12.14
  • >=6.0.0 <=6.6.4
Fixed in
  • 7.5.6
  • 5.12.14
npm@neo4j/graphqlpkg:npm/@neo4j/graphqlOther threatsAffected
  • >=7.0.0 <7.5.6
  • >=5.0.0 <5.12.14
  • >=6.0.0 <=6.6.4
Fixed in
  • 7.5.6
  • 5.12.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the @neo4j/graphql library to version 7.5.6 or later, or 5.12.14 or later. Version 6.x is end-of-life and will not receive a fix, so migration to a supported version is necessary. Patch status is not explicitly stated but the advisory clearly recommends upgrading to these fixed versions.

Description

The @neo4j/graphql library versions prior to 7.5.6 and 5.12.14 have an authentication bypass vulnerability. The library fails to verify the authenticity of a client-supplied, pre-decoded JWT object passed through GraphQL subscription connectionParams. This allows unauthenticated remote clients to forge arbitrary JWT claims and be accepted as authenticated identities, enabling unauthorized access to subscription events restricted to specific roles or users. Versions 6.x are end-of-life and will not receive a fix.

References

Community reviews

Loading reviews…