CVE-2026-54239: faustjs (WordPress plugin) · Insufficient Verification of Data Authenticity
Affects faustjs (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 1.8.11 soon.
Data as of 1 Nov 2026, 11:03 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.8.11
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 17 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Upgrade faustjs and wpengine/faustjs to 1.8.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| wpenginefaustjs | Affected
| Fixed in
|
GitHubwpengine/faustjspkg:github/wpengine/faustjsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the FaustWP WordPress plugin to version 1.8.11 or later, where this vulnerability is fixed. No other mitigation is required as the fix addresses the root cause by properly authenticating the initialization vector in token encryption and decryption.
Description
CVE-2026-54239 is a high-severity vulnerability in the FaustWP WordPress plugin, part of the Faust.js headless WordPress toolkit. Versions prior to 1.8.11 improperly authenticate token data by excluding the initialization vector from the HMAC, allowing a logged-in non-administrator to manipulate tokens. This manipulation can escalate privileges to administrator level, enabling full REST API access, administrator account creation, plugin installation, and arbitrary code execution. The issue is fixed in version 1.8.11.