CVE-2026-54307: n8n · Incorrect Authorization
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 8.5 High · fixed in 2.26.2 : patch n8n soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.26.2, 2.25.7, 1.123.55
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 23 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade n8n and n8n-io/n8n to 2.26.2, 2.25.7 or 1.123.55.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
npmn8n-io/n8npkg:npm/n8n-io/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade n8n to version 1.123.55, 2.25.7, or 2.26.2 or later, where this authorization issue has been fixed. Since the vulnerability is resolved in these versions, applying the official update is the recommended remediation. Patch status is confirmed by the vendor advisory stating the fix in these versions.
Description
n8n is an open source workflow automation platform. Prior to 1.123.55, 2.25.7, and 2.26.2, a member-level user with editor access to a shared workflow could reference credentials they do not own via specific public API endpoints. Credential ownership checks were only enforced partially leading to cross-user credential access. This issue affects instances where workflow sharing is enabled and at least one workflow has been shared with a member-level user as an Editor. This vulnerability is fixed in 1.123.55, 2.25.7, and 2.26.2.