Skip to main content
VulnerabilityPublished

CVE-2026-54310: n8n · SQL Injection

Affects n8nSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.26.2 or 2.25.7 when convenient.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.26.2, 2.25.7
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade n8n and n8n-io/n8n to 2.26.2 or 2.25.7.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • >=2.26.0 <2.26.2
Fixed in
  • 2.26.2
n8n-ion8nAffected
  • <2.25.7
Fixed in
  • 2.25.7
npmn8n-io/n8npkg:npm/n8n-io/n8nOther threatsAffected
  • <2.25.7
  • <2.26.2 >=2.25.0
Fixed in
  • 2.25.7
  • 2.26.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in n8n versions 2.25.7 and 2.26.2. Users should upgrade to at least these versions to remediate the vulnerability.

Description

n8n is an open source workflow automation platform. Prior to 2.25.7 and 2.26.2, an authenticated user with permission to create or modify workflows could supply a crafted parameters to the TimescaleDB and/or legacy Postgres v1 node's allowing arbitrary SQL to be injected and executed against the connected database within the privileges of the configured database account. This vulnerability is fixed in 2.25.7 and 2.26.2.

References

Community reviews

Loading reviews…