Skip to main content
VulnerabilityPublished

CVE-2026-42233: n8n · SQL Injection

Affects n8nSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium · fixed in 2.18.1 : update n8n when convenient.

Data as of 1 Nov 2026, 22:58 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.18.1, 2.17.4, 1.123.32
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade n8n and n8n-io/n8n to 2.18.1, 2.17.4 or 1.123.32.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • >=2.18.0 <2.18.1
Fixed in
  • 2.18.1
n8n-ion8nAffected
  • >=2.17.0 <2.17.4
Fixed in
  • 2.17.4
n8n-ion8nAffected
  • <1.123.32
Fixed in
  • 1.123.32
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threatsAffected
  • <1.123.32
  • <2.17.4
  • <2.18.1
Fixed in
  • 1.123.32
  • 2.17.4
  • 2.18.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is patched in n8n versions 1.123.32, 2.17.4, and 2.18.1. Users should upgrade to these or later versions to remediate the issue. No vendor advisory content contradicts this; therefore, upgrading is the recommended mitigation. Patch status is confirmed by the version information provided.

Description

A SQL injection vulnerability exists in the Oracle Database node's select operation in n8n versions prior to 1.123.32, 2.17.4, and 2.18.1. The flaw allows user-controlled input passed into the Limit field via expressions to be directly interpolated into SQL queries without proper sanitization or parameterization. This can enable an attacker to inject arbitrary SQL commands and potentially exfiltrate data from the connected Oracle database. The issue has been addressed in the specified patched versions.

References

Community reviews

Loading reviews…