CVE-2026-42220: 0xJacky nginx-ui · Information Exposure
Affects 0xJacky nginx-uiSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.3.8 when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade nginx-ui and 0xjacky/nginx-ui to 2.3.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 0xJackynginx-ui | Affected
| Fixed in
|
GitHub0xjacky/nginx-uipkg:github/0xjacky/nginx-uiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade nginx-ui to version 2.3.8 or later, where this vulnerability has been patched. Since the vendor advisory confirms the fix in version 2.3.8, applying this official update fully mitigates the issue. No additional mitigation steps are indicated.
Description
Nginx UI is a web user interface for the Nginx web server. Prior to version 2.3.8, an authenticated user can call GET /api/settings and retrieve sensitive configuration values, including node.secret. The same node.secret is accepted by AuthRequired() through the X-Node-Secret header (or node_secret query parameter), causing the request to be treated as authenticated via the trusted-node path and associated with the init user. This issue has been patched in version 2.3.8.