CVE-2026-42221: 0xJacky nginx-ui · Missing Authentication
Affects 0xJacky nginx-uiSource CVE Database V5
Not known to be exploited · public detection template (Nuclei) · CVSS 8.1 High : upgrade to 2.3.8 soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 1.3% chance of exploitation in 30 days – higher than 71% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.8
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: evidence found.
nuclei template: Nginx UI <= 2.3.7 - Unauthenticated Installer Exposure
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade nginx-ui and 0xjacky/nginx-ui to 2.3.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 0xJackynginx-ui | Affected
| Fixed in
|
GitHub0xjacky/nginx-uipkg:github/0xjacky/nginx-uiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is patched in nginx-ui version 2.3.8. Users should upgrade to version 2.3.8 or later to remediate this issue. Until patched, restrict network access to the installation endpoint to trusted users only to reduce exposure.
Description
CVE-2026-42221 is a high-severity vulnerability in 0xJacky's nginx-ui versions 2.0.0 up to but not including 2.3.8. It allows an unauthenticated remote attacker to claim the initial administrator account during the first-run setup by accessing the public /api/install endpoint without authentication. This leads to permanent takeover of the initial instance by setting the admin email, username, and password. The vulnerability arises because the installation endpoint lacks authentication, and encryption only protects data in transit, not the authorization of the installer. This issue has been fixed in version 2.3.