Skip to main content
VulnerabilityPublished

CVE-2026-42238: 0xJacky nginx-ui · Code Injection

Affects 0xJacky nginx-uiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.0 Critical : upgrade to 2.3.8 as a priority.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.8
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade nginx-ui and 0xjacky/nginx-ui to 2.3.8.

Affected software

ProductAffectedFixed in
0xJackynginx-uiAffected
  • <2.3.8
Fixed in
  • 2.3.8
GitHub0xjacky/nginx-uipkg:github/0xjacky/nginx-uiOther threatsAffected
  • <2.3.8
Fixed in
  • 2.3.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in nginx-ui version 2.3.8. Users should upgrade to version 2.3.8 or later to remediate this issue. Until upgrading, restricting access to the backup restore endpoint during the initial startup period or limiting the privileges of the nginx-ui process user may reduce risk, but the definitive remediation is to apply the official patch by upgrading.

Description

CVE-2026-42238 is a critical code injection vulnerability in 0xJacky's nginx-ui prior to version 2.3.8. The vulnerability arises because the backup restore endpoint is unauthenticated for the first 10 minutes after startup on fresh installations. An attacker can exploit this by uploading a crafted backup archive that overwrites configuration files, allowing arbitrary OS command injection via the TestConfigCmd setting. This command executes with the privileges of the nginx-ui process user, often root in Docker deployments. The issue is patched in version 2.3.8.

References

Community reviews

Loading reviews…