CVE-2026-42223: 0xJacky nginx-ui · Information Exposure
Affects 0xJacky nginx-uiSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.3.8 when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.8
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade nginx-ui and 0xjacky/nginx-ui to 2.3.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 0xJackynginx-ui | Affected
| Fixed in
|
GitHub0xjacky/nginx-uipkg:github/0xjacky/nginx-uiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade nginx-ui to version 2.3.8 or later where this issue is patched. Since the vulnerability is fixed in the official release, applying this update fully mitigates the risk. No other vendor advisories indicate alternative mitigations or that no action is required.
Description
CVE-2026-42223 is a vulnerability in 0xJacky's nginx-ui prior to version 2.3.8 where the GetSettings API handler exposes over 40 sensitive configuration fields to authenticated users. These fields include JwtSecret, NodeSecret, OIDC ClientSecret, and IP whitelist configurations. The issue arises because the protection tag on sensitive fields is enforced only during writes but ignored during reads, leading to unintended disclosure of sensitive information. This vulnerability has been patched in version 2.3.8. The CVSS score is 6.5, indicating a medium severity level.