CVE-2026-54659: ddnexus pagy · Path Traversal
Affects ddnexus pagySource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 43.5.6 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 43.5.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade ddnexus pagy to 43.5.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ddnexuspagy | Affected
| Fixed in
|
AI-suggested
Upgrade to pagy version 43.5.6 or later, where the vulnerability is fixed. No other official remediation or temporary fixes are documented. Until upgrading, avoid using untrusted input for locale settings or sanitize inputs to prevent path traversal sequences.
Description
Pagy is agnostic pagination in plain Ruby. From 43.0.0 until 43.5.6, Pagy::I18n.locale= in gem/lib/pagy/modules/i18n/i18n.rb stored locale values verbatim and later used them as <locale>.yml path components, allowing untrusted params[:locale] values with absolute paths or ../ sequences to create a file existence and readability oracle for YAML files. This issue is fixed in version 43.5.6.