Skip to main content
VulnerabilityPublished

CVE-2026-54722: HackingRepo dssrf-js · Improper Neutralization of Equivalent Special Elements

Affects HackingRepo dssrf-jsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 1.0.4 soon.

Data as of 29 Oct 2026, 07:15 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.0.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade HackingRepo dssrf-js to 1.0.4.

Affected software

ProductAffectedFixed in
HackingRepodssrf-jsAffected
  • <1.0.4
Fixed in
  • 1.0.4
npmdssrf-jspkg:npm/dssrf-jsOther threatsAffected
  • <1.0.4
Fixed in
  • 1.0.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade dssrf-js to version 1.0.4 or later, where this vulnerability is fixed. No other mitigation is specified or required as the fix addresses the root cause.

Description

CVE-2026-54722 is a high-severity vulnerability in the dssrf-js Node.js library prior to version 1.0.4. The issue involves improper neutralization of special elements in URL processing, specifically the '@' userinfo delimiter. This flaw allows an attacker to bypass internal IP validation checks, potentially causing a client to access internal services via crafted URLs. The vulnerability is fixed in version 1.0.4.

References

Community reviews

Loading reviews…