Skip to main content
VulnerabilityPublished

CVE-2026-54892: plug · Inefficient Algorithmic Complexity

Affects plugSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High · fixed in 1.19.3 : patch plug soon.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.19.3, 1.18.3, 1.17.2 +2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
elixir-plugplugAffected
  • >=1.19.0 <1.19.3
Fixed in
  • 1.19.3
elixir-plugplugAffected
  • >=1.18.0 <1.18.3
Fixed in
  • 1.18.3
elixir-plugplugAffected
  • >=1.17.0 <1.17.2
Fixed in
  • 1.17.2
elixir-plugplugAffected
  • >=1.16.0 <1.16.4
Fixed in
  • 1.16.4
elixir-plugplugAffected
  • >=1.15.0 <1.15.5
Fixed in
  • 1.15.5
elixir-plugplugAffected
  • ≥ 712b875d3442c765d8d37e546ffd5ad9f8afcc55, < c317d08fdcf96e17931f7419275b2b8c4bf3e951
Fixed in–

CPE configurations (1)

  • cpe:2.3:a:elixir-plug:plug:*:*:*:*:*:*:*:*

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Until patches are confirmed, consider limiting the maximum allowed nesting depth in request parameters or applying rate limiting to mitigate potential denial of service. Monitor vendor channels for official fixes.

Description

Inefficient algorithmic complexity in Plug's nested-parameter decoder allows an unauthenticated remote attacker to cause denial of service. Plug.Conn.Query.decode/4 (and Plug.Conn.Query.decode_each/2) parse query strings and application/x-www-form-urlencoded request bodies. When a key contains many bracketed segments such as a[a][a][a]=1, the decoder walks the brackets and, for each of the N levels, performs a map operation keyed on an ever-growing binary prefix of the key, hashing the full byte range at each step. The total decode cost is therefore quadratic in the number of nesting levels. With the default Plug.Parsers.URLENCODED body limit of 1,000,000 bytes, a single request can carry roughly 333,000 nesting levels and saturate a BEAM scheduler for minutes. A small number of concurrent requests can saturate all schedulers and render a Plug-based server unresponsive. No authentication or knowledge of application routes is required. This vulnerability is associated with program files lib/plug/conn/query.ex and program routines Plug.Conn.Query.decode/4, Plug.Conn.Query.decode_each/2, Plug.Conn.Query.split_keys/6, Plug.Conn.Query.insert_keys/3, and Plug.Conn.Query.finalize_pointer/2. This issue affects plug from 1.15.0 before 1.15.5, 1.16.4, 1.17.2, 1.18.3, and 1.19.3.

References

Community reviews

Loading reviews…