CVE-2026-55409: filamentphp filament · Cross-site Scripting
Affects filamentphp filamentSource CVE Database V5
Not known to be exploited · CVSS 7.6 High : upgrade to 3.3.53 soon.
Data as of 5 Nov 2026, 11:40 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.6 |
|---|
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.3.53
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade filament and filamentphp/filament to 3.3.53.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| filamentphpfilament | Affected
| Fixed in
|
Packagistfilamentphp/filamentpkg:composer/filamentphp/filamentOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade filamentphp filament to version 3.3.53 or later, where this vulnerability is fixed. No other official remediation or temporary fixes are indicated. Patch status is confirmed by the version boundary provided.
Description
Filament is a collection of full-stack components for accelerated Laravel development. From 3.0.0 until 3.3.53, a disabled RichEditor field rendered its raw state without sanitizing HTML. Where the data stored in this field's state isn't sanitized already when the form state was filled, an attacker could plant malicious HTML or JavaScript and achieve XSS that executes for users who view the form. This vulnerability is fixed in 3.3.53.