Skip to main content
VulnerabilityPublished Updated

CVE-2026-33080: filamentphp filament · Cross-site Scripting

Affects filamentphp filamentSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.3 High : upgrade to 5.3.5 or 4.8.5 soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.3.5, 4.8.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade filament and filamentphp/filament to 5.3.5 or 4.8.5.

Affected software

ProductAffectedFixed in
filamentphpfilamentAffected
  • >=5.0.0 <5.3.5
Fixed in
  • 5.3.5
filamentphpfilamentAffected
  • >=4.0.0 <4.8.5
Fixed in
  • 4.8.5
GitHubfilamentphp/filamentpkg:github/filamentphp/filamentOther threatsAffected
  • <4.8.5
  • <5.3.5 >=5.0.0
Fixed in
  • 4.8.5
  • 5.3.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate CVE-2026-33080, organizations should immediately upgrade Filament PHP to versions 4.8.5 or 5.3.5 or later, where the vulnerability has been patched by properly escaping HTML output in the Table summarizers. In addition to upgrading, developers should implement strict input validation and sanitization on all user-supplied data before storing it in the database to prevent malicious payloads from being saved. Employ output encoding best practices consistently across the application, especially when rendering data in HTML contexts. Conduct thorough code reviews and security testing focused on XSS risks, including automated scanning and manual penetration testing of web interfaces using Filament components. Consider implementing Content Security Policy (CSP) headers to reduce the impact of any potential XSS by restricting script execution sources. Educate developers on secure coding practices related to input handling and output encoding. Monitor application logs and user reports for suspicious activity that could indicate attempted exploitation. Finally, restrict privileges to only necessary users to reduce the risk posed by attackers needing some level of access to plant malicious data.

Description

Filament is a collection of full-stack components for accelerated Laravel development. Versions 4.0.0 through 4.8.4 and 5.0.0 through 5.3.4 have two Filament Table summarizers (Range, Values) that render raw database values without escaping HTML. If there is a lack of validation for the data in the columns that use these summarizers, an attacker could plant malicious HTML / JavaScript and achieve stored XSS that executes for users who view the table with those summarizers. This issue has been patched in versions 4.8.5 and 5.3.5.

References

Community reviews

Loading reviews…